LCD fails when LCD knob turned

I built my Prusa i3 from a kit. After power up, the display indicates I need to calibrate it. When I turn the LCD knob, my display fills with characters. It starts in upper left corner and goes right and down. I've rebooted, reset but nothing changes.

What now?

Answer this question I have this problem too

Is this a good question?

Score 0

Comments:

Since I asked the question, I re-flashed the firmware, no help. I also tried a full reset, but the display just flashes and beeps - apparently it cannot be reset. I did notice that the two Z motors are locked but the Y and X motors are free to move.

by

I'm also having the same problem. Not sure what is going on; rechecked all connections. As soon as turn wheel; just symbols (@#$%&^%$#).

by

Add a comment

1 Answer

I would suspect wiring misconnection on your RAMBo board; I saw something on that subject on another forum. While the manual doesn't mention it other than the second picture off section 8.17, the LCD cables that go into the RAMBo board could go both ways, but only should be going one way. The pictures in the manual do show what color goes where, they just don't warn you to check for it other than that one easily missed picture. This is confusing in the manual as they say the cable with one stripe goes here, the one with two goes here... well, they mean 1 black stripe/2 black stripes. Both cables have one red stripe also, both of which need to be facing the 6 look-alike connectors that the endstops and PINDA probe go into.

Was this answer helpful?

Score 0

Comments:

I triple checked that. Not the case.

by

Add a comment

Add your answer

chris berardi will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 3

All Time: 88