All you need to build a Prusa i3 1.75 kit. You can buy the original at Shop.Prusa3D.com

13 Questions View all

Print fan not turning on

I have everything connected correctly, red cable facing the correct way. But when I do the test print, the print fan never turns on. I have no clue what's going on.

Answer this question I have this problem too

Is this a good question?

Score 6

Comments:

I have this problem too on the Mk2 kit. Tried reversing polarity of the cable to no avail Have tested the fan and it works fine. Should both fans run at the same time?

by

Add a comment

3 Answers

Most Helpful Answer

Have you tried sending GCODE: M106 S255 via an application such as printrun?

Was this answer helpful?

Score 2

Comments:

Didn't know about GCodes until I read your post. Plugged my PC into the USB port, started up a terminal program(in this case PuTTY) set the port speed to 115200 and type in M106 S255 and the fan began to operate. Type M107 and the fan stops. Orientation of the cables for the Mk2 is as per the manual with the red wire closest to the thermistor.

by

Add a comment

The connector on my printer was keyed and the red and black were in the wrong orientation shipped directly from prusa. I had to remove the cables and swap the polarity to get my fan working.

Was this answer helpful?

Score 1
Add a comment

I've solved upgrading to Firmware 3.0.9 and playing with polarity during the selftest. As Angus my kit was shipped with the cables swapped.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Amrak will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 5

Past 30 Days: 22

All Time: 1,240