First Filament Position not feeding completely. Suggestions?

I’ve assembled and installed the MMU2 on my MK3. For some reason, when using the first filament position, it never reaches the head’s filament drive. It does from position 2 and 3. (haven’t tried 4 and 5 yet).

I’ve swapped the following from position 2 without fixing the issue:

The filament (3 different filaments), the spool cradle and the PTFE tubes (long tubes from the spools and the really small tubes between the drive pulleys and the filament selector).

The filament gets past the print head sensor. It just doesn’t get to the drive gears, so the printer doesn’t know there is an issue. My theory is there is some slight delay that makes the amount of filament moved just short of what is required before the print head drive is triggered.

Past the PTFE tubes there is very little that is exclusive to the first position. I’ve checked to see if the pathways are smooth with an undersized drill bit. I’ve double checked the drive pulley in the MMU.

Help! Suggestions?

Update: 4 and 5 won’t load either.

Update (10/08/2018)

I’m not sure why there are 2 places to look but there is another thread on shop.prusa3d.com that is addressing this issue and has lots of info.

https://shop.prusa3d.com/forum/assembly-...

I’ve gotten really far with this information. I’m going to post a bit of info there.

Answer this question I have this problem too

Is this a good question?

Score 5

Comments:

Would testing it by using the first level calibration procedure be different than loading it as if printing? I've been using the calibration method since it seemed quicker and it initially failed on the first filament. I'm not sure if I will have time to check things with a real print before Tuesday. When I do, I'll post the results of that test.

by

Same problem here :(

I checked everything twice… Orange PTFE tube is seated correctly… Tried different FINDA positions…

Every time the filament stops about 3-5mm before the bond tech drive gears :(

Maybe there is a problem with the calculate length of filament which is fed through FINDA to the extruder motor.

Or maybe the orange PTFE tube I got is too long.

Or maybe some parts changed and the distance between FINDA and the bond tech drive gears got larger.

It's a shame that there is no setting in slic3r PE to change the feed length of the MMU :(

I will try to print the filament sensor cover that comes with the MMU kit with a smaller hight and check if this fixes my problem.

EDIT:

Changing the filament sensor cover to a lower hight doesn't work because of the small PTFE tube before the sensor :(

filament 1, 2 & 4 seems to have the same problem

filament 3 seems reliable so far.

filament 5 works some times

It does not depend on the type of filament because the same role of filament works fine in position 2 but do not work for position 1, 2 & 4

Hope there is an easy fix or maybe I just have overlooked something...

I HAVE FOUND A SOLUTION

https://www.youtube.com/watch?v=v1h-S7bx...

@53:20 he explains a secret menu on the mmu 2.0 to reconfigure the feed length.

This seems to work for me and I hope this will fix your problem :)

by

interesting enough I'm having the same issue, but haven't gone far to checking F4-5, Filament 1 works great. Right now my best guess is checking preload tension on the remaining 4 if its the same as Filament 1 it can be that it's pulling harder the remaining lanes which result in friction is causing the short in travel?

by

I am SOOOO incredibly frustrated with this. I disassembled the MMU2 multiple times following the video above and I am no further. I've also disassembled the print head multiple times and now from flexing the wires to the print head so many times, I now have a possible broken wire to the bed level sensor.

I have wasted literally 3 days on this. Days I would have been printing.

I spent 15 years fixing copiers so I'm not a novice at adjusting/building/fixing things.

I'm sorry I purchased this. I had time to cancel and purchase the Mosaic Palette 2 https://www.mosaicmfg.com/products/palet... for more money. Considering the time wasted and I still have nothing that works, I should have. I would recommenced others look into that solution.

Also I feel that there should have some indication as to space requirements. It is a significant increase.

I'm now looking into replacing all the PTFE tubing. I'll update you if this makes any difference.

by

The hobbed gears are not all the same diameter therefore it will never be right until a new FW release where you can calibrate each filament separately. I have 3 gears that are the same and 2 that are oversized by 16 thousands of an inch, this translates into 50 mm length difference of the loading which means you are either not loading or grinding the filament.

Update: Chatted with Shane on the issue and he is sending me a new set of hobbed gears. If they are all similar diameter this should fix the issue for now.

by

Show 2 more comments

Add a comment

5 Answers

Most Helpful Answer

Hi guys,

there is a troubleshooting guide for this, please click here Service menu - bowden length (obsolete)

Note, you are currently able to set one value for all five filaments, we are aware of this and working on a fix.

Was this answer helpful?

Score 2

Comments:

I did it as described. Now when I want to load a filament, the pulley motor turns in the wrong direction (push filament out) and stops after a second. Thats it. Not able to load a filament anymore..

Edit: Found the Problem: A small piece of filament blocked the finda-sensor. I saw it, when I removed the orange tube, and could remove it. The filament had to be torn off at the sensor when the filament was pulled out during the procedure.

=> so if you want to load, and the pulley motor turns in the wrong direction: check this sensor

by

seeing that it now says "obsolete" and link is not followable. how about replacing it with a link that works?

by

Add a comment

After fiddling around with the MMU 2.0 for a while I can confirm the problem with unreliable feedlength.

In my understanding the actual feedlength hardly depends on 2 factors:

  • Diameter of the gears
  • Preload of the springs & hardness of the filament -> lengthening when the teeth cut in

Grinding because of resistance in the filament path should everyone fix by themself. This isn’t a problem of the MMU…

But the feedlength issue need to be fixed in firmeware ASAP.

To prevent grinding when loading filament the MMU pully and the extruder should feed at the same rate.

Was this answer helpful?

Score 1
Add a comment

I cant get my printer to feed enough to reach the bondtech gears in the printer head. At maximum increase of feed in the “secret menu” as above it doesnt even show in the opening around the bondtech gears. I have released the orange bowden and the filament is fed through the bowden but with lowest setting barely visible, and with max increase it is visible around 3.5cm wich isnt enough at all to reach the bondtech gears.

I also tried increasing the height of the F.I.N.D.A in steps to make the filament load more before the F.I.N.D.A senses the filament. But this didnt work either just kept rising until it couldnt sense the filament at all.

One solution would be to shorten the orange bowden but it dont want to do this, at least not yet.

Was this answer helpful?

Score 0

Comments:

Measure the diameter of the hobbed gears and put the one with the smallest diameter for filament #1. The others will overshoot and grind a little but at least they will reach the extruder gears.

by

Add a comment

There is another thread with lots of information that helped me alot. I got my MMU2 working by going through this topic.

https://shop.prusa3d.com/forum/assembly-...

Was this answer helpful?

Score 0
Add a comment

Whereas many persons relate this to extruder diameter difference, mine was not related to that. I had individually calibrated the bowden tubes length.

My single material MMU would start one extruder further then I had configured, so if it had a T0 I would see a transition 1>2 in the display and it would load the second channel. I was streaming the gcode file through Octoprint.

For a multimaterial print, the FIRST extruder specification would load one channel further, but a next occurence of the same T command would load the proper channel.

I "fixed" it by modifying the print settings, GCODE at the start of print and added an EXTRA T0, before the T[initial_extruder] gcode. That resolved it.

for some reason my "first command, so now the T0 I added, was wrongly interpreted but the needed subsequent T[initial...] will now load the correct channel. I updated both the MMU multi material and MMU single material profiles with an extra T0 before the other "T" gcode.

I consider this a work around and not a fix. Seems firmware related, maybe even streaming (Octoprint) specific.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Chuck Genco will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 19

Past 30 Days: 118

All Time: 1,023