XYZ Calibration Fine, but PINDA/hotend crash in to bed

I've upgrade my printer to the Mk2 via the upgrade optio and I've come to the calibration steps and get the following results which after lots of attempts i'm at a loss to explain.

1) Self Test comes back fine

2) XYZ Calibration hits 1st ringed pickup spot fine and proceed with all steps and completes with Slight skew but all good to print message

3) On completion the X-Axis is about 1 cm to the left of the 1st pickup spot right against the endstop

3a) If at this point I run the Z calibration I move the Z axis to the top and hit Yes, it travels all the way down and crashes in to the bed.

3b) If Auto home it instead it moves of the x endstop and sits over the 1st ringed spot. But then running the z calibration does exactly the same it just goes right down and hits the bed.

At all times, no matter how far up or down I move the pinda prob the nozzle will only ever seem to get to about 2-3mm form the bed or I get the crashes.

Any ideas as the forum has been looked over and so have the youtube troubleshooting videos and i'm at a loss.

Answer this question I have this problem too

Is this a good question?

Score 1
Add a comment

3 Answers

Most Helpful Answer

Your PINDA is not correctly placed.

Use this to set the height of the PINDA

Was this answer helpful?

Score 1


Thanks for the reply.

I've had this printed and used it to set the PINDA height but still no matter what I do with the Z calibration while it now completes ok it only ever registers z0.15 as the height on the Info screen and never goes lower.

If I use Live Z Adjust to get it closer I have to set that to -1500 to get it printing cleanly.

Then the next print it forgets and you have to set z live adjust to -3000 .i.e. keep adding to it each time.



I know that the old firmwares had issues to keep PID values, I do not know if it was the same for the Z calibration.

You may try to upgrade your firmware to the latest version :

(seek for FIRMWARE), the latest release is the 3.0.10, and had been released in february 2017.


I try to keep the firmware always at current level so it is already at 3.0.10 and still does the same. The heating seems to be more stable after custom PID settings are entered.

Just cannot get the Z Axis to play ball even after PINDA adjustment using the printed calibrator to get it close to perfect.

On XYZ calibration it is almost perfect above the heatbed but as soon as you try and print the calibraionv2.gcode it does the initial bed levelling and moves the zAxis up to about 30mm off the heat bed and fails to find any calibration spots and asks for a reset.

This then kills the PINDA and the light never comes back on until you power the printer off at the mains for a good hour or so, I assume to drain capacitors etc.

So really looks like firmware not PINDA that is my issue.


Add a comment

I have this problem as well, any other solution?

Was this answer helpful?

Score 0
Add a comment

@fjn777 It turned out the Pinda was faulty. I contacted Prusa support who were really good at sending out a replacement. Worked fine ever since.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Joe Powell will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 12

All Time: 400