Knob on LCD fails selecting menu item


I have just completed my Prusa Kit i3 MK2, switched it on and LCD indicates calibration (as expected). When I try to turn the knob, nothing happens, I can see the menu. Pressing the knob is working, but not the turning, therefore it is useless.

Could you please suggest a solution.


maybe firmware update?

faulty knob?

I double checked wiring, all good, LCD works perfectly.

Thank you for your help.


Answered! View the answer I have this problem too

Is this a good question?

Score 2


In the meantime I have updated firmware and unfortunately there is no change. Still faulty knob. Need your help. Thank you.


Add a comment

2 Answers

Chosen Solution

Customer support has given me the solution:

1.turn off the machine and disconnect all cables between Rambo and LCD

2.stretch well all the cables

3.Reconnect again and turn on machine

To be honest, I never expected this to work but it DID!

Huge thank you for them.

Problem solved.

Was this answer helpful?

Score 1
Add a comment

It's kinda worrying that this worked - but it worked for me too.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Andras Farkas will be eternally grateful.
View Statistics:

Past 24 Hours: 1

Past 7 Days: 1

Past 30 Days: 9

All Time: 245