LCD wont turn on, just beeps loudly

When I push the button to turn on the LCD, the screen flashes on and I get a loud beep as I hold the button in. What am I doing wrong?

I've checked my electrical connections multiple times.

Answered! View the answer I have this problem too

Is this a good question?

Score 3

Comments:

Hi, i am not really running an i3 mk3, but i purchased an original einsy rambo to run in my homebuilt printer. I have a standart reprap lcd connected. I either have the beep (green led on on the board, and a red and yellow one before the beep) or a black screen when i swap cables (only green led on). Is there any documentation on the leds on the board? Do i need to have the power panic or anything else connected to boot it up?

by

Hi Matthias (@matchmo), Einsy RAMBo is manufactured by Ultimachine. Try finding your answer on their Wiki http://reprap.org/wiki/EinsyRambo

by

Hi Jakub,

I know, and I have tried. They however distinguish between boards sourced from them and from you, and I bought one as a MK3 spare part. It had a PrusaResearch test slip with it. So I believe the MK3 Firmware is on it? Is there anything that will be checked by the firmware before the LCD turns on?

The LCD used to work with a ramps 1.4 board with smart adapter.

by

Hi Matthias,

in case you have our version, try searching the GitHub, the firmware is uploaded as a source code, so I think it will be possible to get to the LCD sequence, change to your needs and recompile: https://github.com/prusa3d/Prusa-Firmwar...

by

Thank you, Jakub!

by

Show 1 more comment

Add a comment

5 Answers

Chosen Solution

I had the same problem

I flipped both cable at the RAMBo, so the pink strip is facing down .

And it works!

Was this answer helpful?

Score 1
Add a comment

Hi.

The LCD cables are not shielded. Sometimes this creates an issue.

You can use ferrites, or try aluminium foil around the flat cable. It might correct the issue (BE CAREFUL to not create any shortcut with the foil !!!!!!)

Was this answer helpful?

Score 0
Add a comment

Did you solve this issue? I have the same problem

Was this answer helpful?

Score 0

Comments:

Hi Alex, please try to rotate the LCD connectors inside RAMBo cover, so the pink strip is facing down and let me know if it helped.

by

Add a comment

I do have the same problem. Pink strip on the cables already facing down.

Was this answer helpful?

Score 0

Comments:

Resolved, Pink strip had to be top side.

by

what do you mean pick strip topside? do you have pictures

by

Add a comment

Hi All, So I am having this issue with my Hictop I3 - I have tried every combination of connecting the leads. But still getting the beeping.

Ive never had this issue before, any help would be greatfull

Was this answer helpful?

Score 0

Comments:

Hi Stuart, I'm sorry but your printer is produced by company Hictop using our design, please try to contact them.

by

Add a comment

Add your answer

Brian White will be eternally grateful.
View Statistics:

Past 24 Hours: 2

Past 7 Days: 8

Past 30 Days: 50

All Time: 691