i3 MK2 Firmware 3.0.11 and 3.0.12 - odd behavior of Z axis

I've tried upgrading my firmware to v3.0.11 and v3.0.12 and have ended up with significant printer issues. The issues seem to be related to the Z axis - initially crashing the build plate, gaps in layers on prints, and inaccurate bed leveling (even though the bed level process passes). I've had to revert back to v3.0.10 - which works fine.

After the FW upgrade, I always have to recalibrate the XYZ. I've triple checked to ensure I have the correct FW and latest firmware update software but cannot get the printer to print properly after upgrading beyond 3.0.10.

Any thoughts on how to troubleshoot?

Answer this question I have this problem too

Is this a good question?

Score 0
Add a comment

2 Answers

Hi Gilbert,

please try to update to the latest firmware for MK2.

Was this answer helpful?

Score 0
Add a comment

I updated to the current software and firmware from Dec 2017. I had to re-calibrate the bed leveling. The re-calibration process and live adjust-z went fine.

Now when I try to print, the first layer is fine but after the first layer the Z axis elevates significantly although the display indicates that the z-axis has only gone up 0.2mm. On the second layer print, I can see a significant gap between the print head the the previously layer ~1+mm. I tried several files that had printed successfully with the old firmware but they will not print with the new firmware. I've also noticed that if I cancel a print, the z-axis will elevate to the top and grind there for few seconds before stopping.

Other Prusa owners in my community have reported similar z-axis issues - one person says he successfully upgraded by using Linux vs Windows when running the firmware upgrade from the PC.

Could the issue be in the Windows based Prusa firmware update software?

Was this answer helpful?

Score 0
Add a comment

Add your answer

Gilbert Carmichael will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 1

Past 30 Days: 2

All Time: 53