Original Prusa i3 MK2S is a successor to Original Prusa i3 MK2 with small hardware tweaks for easier assembly and improved reliability.

79 Questions View all

Self Test Error: End Stop Wiring Error Z

Block Image

Hello,

I have just completed my assembly of my new Prusa i3 MK3 3D printer.

However, when I start it up and tried to run the self test, I am getting End Stop Wiring Error Z.

I have checked the connection countless of times, removed and reconnect all connections including PINDA probe connection on the Rambo board.

This is very frustrating as I was looking forward to start printing..

Please help!

Regards,

Firdaus

Answered! View the answer I have this problem too

Is this a good question?

Score 1
Add a comment

2 Answers

Chosen Solution

Hi Mohamad,

endstop for Z axis is PINDA probe, so there might some issue. Lets make a simple check:

1) Power on printer

2) Using knob enter menu

3)Go to Calibration

4)Go to Show end stops

5)There are all endstops with values "0" (zero), but if you place something metal below PINDA probe, the value must change to "1" (one)

Let me know, if the value is changing or not. Thanks

Was this answer helpful?

Score 2
Add a comment

Hello Jakub,

Yeah it's a problem with the PINDA probe.

I spent a good couple of hours troubleshooting this just to confirm.

Did some googling to confirm End Stop Z = PINDA probe.

1. Checked End Stops Diag, first X & Y showing "0" and the Z showing "1"

2. Removed connections from Rambo board and reconnect, no changes in the values.

3. Swapped the Y with Z, checked the end stop diag and this time Y = 1 and Z =0

So definitely an issue with the PINDA probe.

I have reached out to Prusa support and they have quickly dispatched out a replacement for me. =)

Thanks again for your inputs!

Block Image

Block Image

Block Image

Was this answer helpful?

Score 1

Comments:

Hi Mohamad, you're welcome, I'm glad it helped ;)

by

Hello Jakub, and thanks Mohamad for the question.

I now have this same error and I have done the check of endstops. The Pinda does change to 1 with a metal object.

What would be the next sugestion to check?

I and examined the wire runs of the Z motors and unplugged and re-plugged both the Z motors. Still the same error. I recently replace the PINDA probe and it has been work for about 2 months now with no issues.

All input and suggestions welcome!

MR

by

Hi Malcolm, it might be the PINDA got broken again. Please contact our support using live chat (head to the eshop site) and discuss it with them, so you can get a replacement immediately ;)

by

Yes, confirmed Jakob, I had purchased 2 spare PINDA probes. I ruined the original one, the second one is the one mentioned above and it has now been replaced with the 3rd one. Once Z height was again calibrated I am back in business!

And yes I have been in touch with the great guys in online help and have 2 more probes on order.

Cheers

Malcolm

by

Hi Malcolm, good to hear your printer is printing again! Make sure the cable is guided as in the manual and there are no sharp edges, which might damage it over time.

by

Add a comment

Add your answer

Mohamad Firdaus Hasbullah will be eternally grateful.
View Statistics:

Past 24 Hours: 3

Past 7 Days: 16

Past 30 Days: 64

All Time: 509