Why multi extruder commands are only outputting on first extruder?

I just assembled my mk2/s with multi-material and I cannot trace where my issue is coming from. The issue is while the controls on LCD for extruder 1 work perfect, if I load/unload extruder 2 or 4, it makes extruder 1 function opposite direction rotation. Controlling extruder 3 makes extruder 1 work but with correct load/unload rotation. I have compared/contrasted this issue with the manuals/wiring and combed this over for the last few hours and I am stumped. Everything seems connected as pictured.

I have not attempted any printing since assembly, but it has been updated with the Rambo1.3MM firmware from website and passed all calibrations. I have not received any functions from extruders 2,3,4 yet. Any ideas?

Answered! View the answer I have this problem too

Is this a good question?

Score 1


My fault, Cable from multi board was not plugged into the open pin connection properly. Finished a couple multi prints so far. Working well except for some hang ups switching filaments in multiplexer. Thanks for your help!


Add a comment

3 Answers

Chosen Solution

Hi Christopher,

for the start, please recheck again all connections, connectors must be fully seated.

Next try to make the full factory reset:


Then flash the firmware for MM again:


Let me know if it helps, if not, we will proceed further. Video will be great so I can discuss this with colleagues ;)

Was this answer helpful?

Score 3
Add a comment

I too am running into a similar issue. I have checked all the connections to make sure the plugs are seated properly. Everything seems to be fine there, although I did find that I had reversed all the stepper motor plugs. This is now corrected. I've tried the full factory reset, but can't confirm whether I flashed the firmware before or after (I blame the Canadian beer for this).

I'll try @jakoob steps above in order and see if that solves my issue (I think it will). If not, I'll take some video of the issue and post it back here.



Was this answer helpful?

Score 1


My issue ended up being the same as Christopher's. Due to lack of visibility I had accidentally lodged the plug between the pins and plastic cable holder above it. Connected it properly and all motors are working as they should.


Glad to hear it is solved Adam, enjoy your MMU ;)


Add a comment

I found the same thing.

After I upgraded my Prusa i3 Mk2 to multi-material, only the first extruder worked, and it ran backwards.

After I flashed the multi-material firmware, all four extruders could be addressed and they ran in the correct direction.

Was this answer helpful?

Score 0
Add a comment

Add your answer

Christopher Murray will be eternally grateful.
View Statistics:

Past 24 Hours: 0

Past 7 Days: 0

Past 30 Days: 5

All Time: 229